docker 报错 library initialization failed - unable to allocate file descriptor table - out of memory
错误
docker容器,启动的时候 容器日志报: library initialization failed - unable to allocate file descriptor table - out of memory
原因
docker启动容器时,若未给容器配置ulimit,则从docker守护进程上设置的默认ulimits继承,这个值太大?会报这个错
官方文档:
dockerd | Docker Docs
ulimit nofile这个值太大报错的原因:
JDK8启动程序时会尝试为文件句柄分配内存,文件句柄数即系统设置ulimit nofile的值,若ulimit nofile很大,文件句柄数量十分巨大,就导致了即便分配10G运存还是Out Of Memory。旧版的Linux默认句柄数为1024,则不会出现该异常。
解决方法
修改创建创建容器时的ulimit值,
这个是在启动容器的时候报错,而不是启动docker的时候,对整个系统影响最小的话,
优先修改的是docker创建容器时的ulimit值(法1),但这种每次都要加参数比较麻烦
所以推荐改docker守护进程的ulimit(法2),对整个系统影响最小的话,也不麻烦
还有就是修改系统内核的(法3),对整个系统影响较大不推荐
方法1
docker run 或者docker-compose的时候加上ulimit配置。
docker run | Docker Docs
Services top-level elements | Docker Docs
方法2(推荐)
修改docker创建容器的默认ulimit配置。
步骤如下:
查看docker的systemd配置位置

systemctl status docker
编辑docker.service
在ExecStart命令后加上创建容器的默认ulimit配置,如下,设置容器启动时的ulimit为65535:65535:
--default-ulimit nofile=65535:65535
配置好的样子
ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock --default-ulimit nofile=65535:65535
重启docker
systemctl daemon-reload
systemctl restart docker
方法3
修改系统内核的ulimits
使用 ulimit 命令:
ulimit -n <new limit>
修改 /etc/security/limits.conf 文件:
在 /etc/security/limits.conf 文件中添加或修改以下行:
* soft nofile <new limit>
* hard nofile <new limit>
使用 sysctl 命令:
sysctl -w fs.file-max=<new limit>
